We are glad to welcome you to our Community Support Forums!
These forums are your way of communicating with the community of people developing and using tools provided by the OneAll platform.
The forums are run by the community and moderated by the OneAll team during office hours. Please stick to technical issues - and remember, no confidential information - these are public forums!

Don't show the Social Login buttons in the comment area

edited July 11 in WordPress
Hi.
I have an error because don't show the Social Login buttons in the comment area, instead appear the source code.

Attached image

Thanks

https://drive.google.com/file/d/0BzrjBbvPNFfyWVcyUlp3MVF2WVE/view?usp=sharing

Best Answer

  • Answer ✓
    It was finally a problem with the theme used.

    It is already fixed and works perfectly.

    Thank you very much for your patience and sorry for the inconvenience.

Answers

  • Hello,

    could you please post a link to the page?

    Regards,
  • Sorry, I only see a spinning logo ROC on that page.
  • I do not know what may be happening.
    I have tested the access from several browsers and several Pcs, besides IPs of UK and USA. Everything works normally.

    The problem appears in both entries and events.

    Please try blog page: http://www.racingonlineclub.com/web/blog/

    Thanks
  • edited July 11
    Sorry, but as much as I change and review the settings, I can not correctly display the icons in the comment area.

    Instead of the icons, it shows me this code:

    var _oneall = _oneall || []; _oneall.push(['social_login', 'set_providers', ['facebook','google','steam','twitter','windowslive','youtube']]); _oneall.push(['social_login', 'set_callback_uri', (window.location.href + ((window.location.href.split('?')[1] ? '&': '?') + "oa_social_login_source=comments"))]); _oneall.push(['social_login', 'set_custom_css_uri', 'http://public.oneallcdn.com/css/api/socialize/themes/wordpress/default.css']); _oneall.push(['social_login', 'do_render_ui', 'oneall_social_login_providers_9085953']);

    The page shows:

    image

    Link to that page, although this happens with all pages and post that support comments:

    http://www.racingonlineclub.com/web/racing-online-club-estrena-nueva-pagina-web/


    If there is no solution, I will have to disable the icons in the comment area from:

    Comment Settings

    Show the Social Login buttons in the comment area?
    Yes, show the Social Login buttons (Default)
    -> No, do not show the Social Login buttons

    Show the Social Login buttons in the comment area if comments are disabled for guests?
    The buttons will be displayed below the "You must be logged in to leave a comment" notice.
    Yes, show the Social Login buttons (Default)
    -> No, do not show the Social Login buttons

    Any idea from what's happen?

    Thanks in advance
  • Hi Josep,

    I have now tried with another browser, and there I can see your website.

    Could you please try to set this:
    Show the Social Login buttons in the comment area if comments are disabled for guests?

    To:
    No, do not show the Social Login buttons

    I would like to know if the code is still displayed after having displayed it for guests.
  • Option disabled and the code not appears

    Also, What is the difference between:

    "Show the Social Login buttons in the comment area?"

    And

    "Show the Social Login buttons in the comment area if comments are disabled for guests?"

    I think the first question don't have any sense because if I'm logged (no guest) I don't need to re-login with social account.
  • edited July 13
    Hi Josep,

    on your blog comments are disabled for guests.

    Show the Social Login buttons in the comment area?
    If enabled, Social Login will be displayed above your comments.
    If the comments aren't displayed (if they are disabled for guests for example) Social Login won't be displayed either.

    Show the Social Login buttons in the comment area if comments are disabled for guests?
    If you have disabled guest comments in your WordPress settings (like you have at the moment), then guests will only see a message like "Please login to leave a comment". By enabling/disabling this option you can show/hide Social Login below that message.

  • edited July 13
    Ok I understand. It's a bit confusing because if I select "NO" to the first question, I understand that the second one is meaningless or unusable.

    But well, the thing is, what I would like is that, when a guest wants to publish, have the login icons with social networks, which is precisely what I fail.

    That is, I want the two options in "YES", but it does not work.

    Is there no idea why this part fails? The rest works wonderfully.

    If you need me to activate the login in the comments to see the error, you just have to tell me.

    Thank you.
  • edited July 14
    Hi Josep,

    It's a bit confusing because if I select "NO" to the first question, I understand that the second one is meaningless or unusable.

    Yes, are are absolutely right. If you disable Social Login in the comments area, it won't be displayed for guests either, even if the second option is enabled.

    When you had the second option enabled, I had a look at your website. What you had is something like this:

    var _oneall = _oneall || []; _oneall.push(['social_login', 'set_providers', ['facebook','google','steam','twitter','windowslive','youtube']]);
    _oneall.push(['social_login', 'set_callback_uri', (window.location.href + ((window.location.href.split('?')[1] ? '&': '?') + "oa_social_login_source=comments"))]);
    _oneall.push(['social_login', 'set_custom_css_uri', 'http://public.oneallcdn.com/css/api/socialize/themes/wordpress/default.css']);
    _oneall.push(['social_login', 'do_render_ui', 'oneall_social_login_providers_9085953']);


    The problem is that the script tags are missing. The code should be inside a tag like this:

    <script type="text/javascript">
    Code Here
    </script>


    So there must be something (another plugin maybe) that removes the script tags.
    Could you tell me which plugin you are using for the comments?
  • I am not using any plugin for comments.

    Maybe it is a problem of the theme itself, I will ask in its support and I will transmit what they say to me.

    Thank you.
Sign in with your OneAll account to take part in the discussion.