In Zen Cart, social icons not appearing in sidebox

edited July 2015 in ZenCart
Installation when smoothly. It appears in the admin and the API credential verified. But no icons appear in the Connect with sidebox.

I believe I set-up the allowed domains correctly. The site url is:
http://dollarbead.com/dev/

The allowed domains are:
dollarbead.com
*.dollarbead.com

Best Answer

  • Fred_PinelFred_PinelMember
    Answer ✓
    Hi,

    Well, first, you have to download library.js (this is the asynchronous version)):
    <script type="text/javascript"> /* Replace #your_subdomain# by the subdomain of a Site in your OneAll account */ var oneall_subdomain = '#your_subdomain#'; /* The library is loaded asynchronously */ var oa = document.createElement('script'); oa.type = 'text/javascript'; oa.async = true; oa.src = '//' + oneall_subdomain + '.api.oneall.com/socialize/library.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(oa, s); </script>
    Then, you need to add this code where you want the icons to show:
    /* Initialise the asynchronous queue */ var _oneall = _oneall || []; /* Social Login Example */ _oneall.push(['social_login', 'set_providers', ['facebook', 'twitter', 'linkedin', 'google', 'yahoo', 'foursquare', 'blogger', 'github']]); _oneall.push(['social_login', 'set_callback_uri', 'http://www.oneall.com/callback/']); _oneall.push(['social_login', 'do_render_ui', 'social_login_demo']);
    Hope this helps.

Answers

Sign In or Register to comment.