Avatar of people vk.com was loaded on HTTP (mixed content)

Hello! Please solve this problem! I use SSL and HTTPS 443 (in a plugin settings)
Screenshot of problem https://yadi.sk/i/Hxcl_q3HiyuZU

Best Answers

  • Answer ✓
    Unfortunatelly, this is don't solve my problem: https://yadi.sk/i/oQAukdXLizBnQ
    Support of vk.com tell me how to solve this problem:
    "When you call a method that allows to obtain the path to the photo, send the setting: https=1"
  • Fred_PinelFred_PinelMember
    Answer ✓

    The https links to Vkontakte photos should be available now.
    Make sure to remove the code fix (above).



  • Hi,
    You can fix it on your wordpress installation (we will fix it in our plugin).
    1. open the file plugins/oa-social-login/includes/user_interface.php:
    2. locate the lines (around line 639):
    if ($user_picture !== false AND strlen (trim ($user_picture)) > 0)
    3. Insert the following code immediately after the previous lines:
    if ($user_picture !== false AND strlen (trim ($user_picture)) > 0)
        $user_picture = str_replace('http:', 'https:', $user_picture);

  • Fred_PinelFred_PinelMember
    edited September 2015
    Indeed, the https photos links are different to the http ones, so our fix does not work.
    We're going to fix this shortly, thanks to your link to the extra parameter.

  • Thank you! I will be wait.
  • Thank you!
  • No problem.

    Just to confirm: does this work now?

  • Yes! This work now!


Please sign in to your OneAll account to ask a new question or to contribute to the discussions.

Please click on the link below to connect to the forum with your OneAll account.