sharing_message_token is missing from response body

According to the API documentation, sharing_message_token is returned for publish actions. And then we can use sharing_message_token to request analytics snapshots.

We have built our integration around this, and it has been working very well (including fetching the snapshots).

In the last couple of days the responses have STOPPED including the sharing_message_token element.

Is this a bug, or an undocumented change. And if it is a change, how are we to fetch analytics on published content.

We have a high-profile event launching tomorrow so it is urgent to us to solve this problem.

Best Answer


  • Where is the best place to subscribe for updates to API changes? While we may not have been using the correct API endpoints, the endpoints WERE giving us responses that worked, gave us message tokens, and those tokens worked in the Analytics endpoints.

    It's important to us to be able to get updates on API changes - even one like what seems to have happened here where an endpoint was changed to have the "correct" behavior, which has now broken some pieces of our integration.


Please sign in to your OneAll account to ask a new question or to contribute to the discussions.

Please click on the link below to connect to the forum with your OneAll account.