Loudvoice Wordpress plugin issue: sidebar is pushed down the page

edited February 2017 in WordPress

I use the Loudvoice plugin for WordPress. Latest versions of both (all installed a few days ago).

The sidebar moves below the blog post and Loudvoice comments (remaining at the right side however) when I activate LoudVoice. When I deactivate the Loudvoice plugin, the sidebar shows on top where is should appear.
This issue only appears on all blog posts, not on home page or static pages.

(The sidebar appears correctly)
This is a print screen of the Homepage: http://prntscr.com/e0c0b4
Original URL: https://peterblogs.be/

(The sidebar is pushed down the page)
This is a print screen of a blog page: http://prntscr.com/e0c110

How can this be fixed?
Thanks, Peter


  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team
    edited January 2017
    Hi Peter,

    the wrongly displayed sidebar is probably due to an error in your HTML Code (eg. an unclosed div tag).
    Could you please re-enable LoudVoice, I will then have a closer look at your HTML.

  • re-activated - here you can see it going wrong: https://peterblogs.be/scrum/product-owner-1-pager/
  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team
    Hi Peter please have a look here:

    Especially error 6:
    Error: End tag div seen, but there were open elements. From line 290, column 17; to line 290, column 22

    Fixing these error should also fix the issue with the sidebar.
  • It seems that Loudvoice is causing this error in html.

    I deactivated all plugins => no issue.
    I activated Loudvoice only (all others remain deactivated) => html break
    I deactivated Loudvoice + reactivated all other plugins => no html break issue
  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team
    Hi Peter,

    I could not detect any HTML errors in our plugin. It's possible that without LoudVoice the HTML is correct because there are two HTML errors and the second one "corrects" the first one.

    It seems like you have changed your theme? Could you give it a try with the new theme?
  • peterblogspeterblogsMember
    edited February 2017
    Hi Claude. I replaced the whole theme as I tought it was due to an error in the theme, and guess what: the same problem appears. It appears on https://peterblogs.be/geen-onderdeel-van-een-categorie/hello-world/
    So I guess it is not the WP theme causing the problem.

    The theme I use now is BeTheme.

    On https://wordpress.org/support/topic/loudvoice-throwing-off-theme/ , the same problem is registered.
    Somehow the plugin is putting the
    outside of
    . Normally “sidebar” is within “single_post.
    > I checked, and manually tried to move the div class="sidebar sidebar-1 four columns" to above the above. The layout gets right.
  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team
    edited February 2017
    Hi Peter,

    thank you very much for the testing and sorry for the assumption that the error was in your theme.
    We are currently working on the LoudVoice plugin to add and option to disallow guest postings.

    At the same time we will also analyze the error with the HTML.
    The update will come in the next few days.

    Best Regards,
  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team
    Hi Peter,

    we have finally been able to find an fix the HTML error in the plugin.
    You can simply open the plugin list in your WordPress admin area and update LoudVoice to version 1.2

    This should fix the error.

    Best Regards,


Please sign in to your OneAll account to ask a new question or to contribute to the discussions.

Please click on the link below to connect to the forum with your OneAll account.