These forums are your way of communicating with the community of people developing and using tools provided by the OneAll platform. The forums are run by the community and moderated by the OneAll team during office hours.
Please stick to technical issues - and remember, no confidential information - these are public forums!

Login error after Facebook enabled by default Use Strict Mode for Redirect URIs

Hello guys,
It look s like facebook login does't work after they've turned on Use Strict Mode for Redirect URIs.
Anybody with the same issue?
Any solutions?

Best Answer

Answers

  • edited March 19

    I encountered this problem as well. OneAll has added a description for how to update the FB settings, but the instructions contain an error. There is a missing uri that needs to be validated. These are the steps as they are listed now. Note that 3. and 4. are identical, so nr 4 is missing. The missing uri is actually listed in the url for the error message on my site, but when I validate it, it still does not work. (It seems that the WP-plugin must make local changes to permissions to make it work.)

    1. Open the Facebook Login \ Settings of your Facebook app.

    2. Set Use Strict Mode for Redirect URIs to YES.

    3. Enter this value in Valid OAuth redirect URIs:
      http://(name of my site).api.oneall.com/socialize/callback.html

    4. Enter this value in Valid OAuth redirect URIs:
      https://(name of my site).api.oneall.com/socialize/callback.html
    5. Save your settings!
  • hi. So what was the fix? I think i have a similar problem. you can't enter http addresses, is there a second URL i should be adding?

  • edited March 23

    Hello,

    please note that these are two different URLS:

    Enter this value in Valid OAuth redirect URIs:
    http://(name of my site).api.oneall.com/socialize/callback.html

    Enter this value in Valid OAuth redirect URIs:
    https://(name of my site).api.oneall.com/socialize/callback.html

    The one is with https and the other with http.
    As indicated in the guide, you need to add both of them.

  • Thanks! However, even when I have both, I get this error message when trying to use social login:

    URL Blocked: This redirect failed because the redirect URI is not whitelisted in the app’s Client OAuth Settings. Make sure Client and Web OAuth Login are on and add all your app domains as Valid OAuth Redirect URIs.

  • Still having this problem. Any thoughts on what might be wrong?

  • Could you please post a link to your website? I will have a look.

  • Darn, I didn't notice your response until now. Thanks a lot for being willing to look at the problem!

    This is the website: http://gamephilosophy.org/ It is under login for members.

    Let me know if you need further info..

  • Hi John,

    I'm sorry but you don't seem to be using our services.
    Do not hesitate to contact us if you want to give it another try.

    Regards,

  • I don't understand. This worked until the FB-change some time ago. This is the info I get when I'm logged into the dashboard at oneall:

    Sites
    Site Subdomain #Users Current Plan
    Gamephilosophy.org gamephilosophy 1 Freemium Domains Social Networks

  • ah. Mystery solved! Thanks. It works now, I think.

This discussion has been closed.

Welcome!

Please sign in to your OneAll account to take part in the discussions.

Please click on the link below to connect to the forum with your OneAll account.