These forums are your way of communicating with the community of people developing and using tools provided by the OneAll platform. The forums are run by the community and moderated by the OneAll team during office hours.
Please stick to technical issues - and remember, no confidential information - these are public forums!

Unable to share posts to any social websites except Twitter

We are using the OneAll API on our website for social sharing. We are using a CMS called Jamroom. Our users are reporting that when they try to share their posts through our platform to their connected media networks (Facebook, LinkedIn, Twitter, etc.), their posts are not showing up on those social media sites. We have made sure that all of our settings are correct and were advised by a OneAll support staff previously that the settings were correct and the issue must be on our side. With the help of the developers of our CMS, we spent several days trying to find the cause of the issue was but could not find anything on our end. However, what we did find is that we are getting successful status codes from the OneAll API for all of the configured sharing networks. Upon seeing this, our CMS developers have determined that the issue is not on our side. Not sure what could be causing the issue here, but according to the API response, these posts should be getting shared and they are not. Any help here would be much appreciated. Thank you!


  • edited April 27

    Hi Adam,

    could you please give me your OneAll subdomain?
    This will allow me to have a closer look at our logs.


  • The subdomain is "tunetrax".

  • Hi Adam,

    could you please do another push? I have now enabled our internal debugging for your application. Please keep me informed once you have done it and I will have a closer look.


  • Just did another push. Works for Twitter, but not for facebook or linkedin. Here are the profiles it should be showing up:

  • edited May 11

    Below you can see the result of your push.

    • Facebook : You do not have the permission to post on behalf of that user.

    FIX: Enable the permission "Publish Actions - Post comments and likes on behalf of a user" in the Facebook settings in your OneAll account and then have the user re-login in order to update the permissions.

    • LinkedIn: The content that you are trying to post is incomplete.

    FIX: Either include the node [text->body] and/or both nodes [link->caption] and [link->url]. This is something that only Jamroom can fix.

    • Twitter: The user that you are trying to post for has no Twitter identity.

    FIX: Have the user connect his Twitter account.

    Our API always returns the error and a corresponding message. Jamroom should parse those error message and display them to their users.

                "date":"Thu, 10 May 2018 17:07:12 +0200",
                    "info":"Your request could not be processed due to an error"
                        "date_creation":"Thu, 10 May 2018 17:07:12 +0200",
                                        "message":"The provider did not accept the message: you do not have the permission to post on behalf of the user"
                                        "message":"The provider did not accept the message, it is incomplete: The message must contain the node [text->body] and\/or both nodes [link->caption] and [link->url]"
                                        "message":"The API could not publish the message: the user has no identity for Twitter"
  • I did the Facebook fix by enabling "Publish Actions" and did another push, but post is still not being shared to Facebook.

    As for LinkedIn, I will contact the Jamroom developers about implementing the fix noted above.

    And for Twitter, the post was successful. I am not sure why the API is returning that error. The account we are testing with definitely has Twitter connected and has a Twitter identity, and posts are being shared as expected. You can see the twitter page here:

  • Sharing to Facebook is still not working. Any other suggestions on how to fix? Thank you.

  • Both [text->body] and the [link->caption] [link->url] should be being sent from jamroom. When I try to debug the situation I send this:

    and the response is

    Linkedin responds with 'error_message_is_not_permitted' status

  • edited May 17

    Thanks for the input, Michael. However, the main issue I am still having is with Facebook sharing. I am working with Jamroom to resolve LinkedIn.

    EDIT: Whoops, I didn't realize you were the same Michael from the Jamroom team.

  • Claude, we are still having an issue with Facebook and LinkedIn sharing.

    For Facebook: I made the change to the settings as you described above, as well as unlinked and relinked our testing profiles, but the posts are still not being shared to Facebook.

    For LinkedIn: Michael, a developer from the Jamroom development team, has posted above about LinkedIn sharing and he is not seeing an issue with what they have implemented.

    This is an urgent manner for us and we hope to get this resolved soon. We appreciate your diligence helping us to resolving this manner. Thank you.

  • Claude,

    Where do we stand on this? This issue has not been resolved

    We need to find an urgent resolution to this.



  • I too am a Jamroom user and I am currently on the Bronze Plan. Do you know how much longer this is going to take? I would like to seek a refund if it is going to take another month.

  • edited July 10


    the issue is in fact in your configuration. If you have a look at the second screenshot in Michael_Ussher's post, you can see this error message: "You do not have the permission to post on behalf of the user".

    To be able to post on behalf of the user, you first need to get his permission to do so. For LinkedIn in you need to enable the option "Share content - Post content on behalf of the user" in the LinkedIn settings in your OneAll account.

    If this option is enabled, then the user will be asked for that permission when he logs in with LinkedIN. Once the permission has been granted, you can post on his behalf.


Sign In or Register to comment.