Getting an error when trying to register a new member via Twitter

I am getting an error when trying to register a new member via Twitter:

An Error Has Occurred!
Unable to load the 'oneall_social_login_registration' template.

Here is my registration page if you would like to try and reproduce it: https://docbrockgames.com/thenode/index.php?action=register

Here is a screenshot:

Answers

  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team

    Hello,

    I just made a test. Facebook works correctly, but that wasn't the problem ;)

    For Twitter I might have an idea, but I cannot reproduce the error.
    Registration does not work, but I do not get the error from your screenshot.

    Have you made any modifications in the meantime?
    Could you also have a quick look at your PHP error logs and see if there is anything related to Social Login?

    Best Regards,

  • Thank you for testing!

    There are no errors in my server's PHP error log; however, my forum error log shows the error I previously posted when I try and register like I attempted again today:

    https://docbrockgames.com/2020-11-14_Registration_Error.png

    I have made modifications.

    1. I removed the following code from index.template.php:

    https://docbrockgames.com/01_Removed_from_index.template.php.txt

    1. I added the following conditional statement around template_menu() in index.template.php:

    https://docbrockgames.com/02_Conditional_statement_added_to_index.template.php.txt

    1. In Login.english.php I made new settings to the following 3 variables:

    ORIGINAL:
    $txt['agreement_policy_agree'] = 'I accept the terms of the agreement and privacy policy.';
    $txt['registration_form'] = 'Registration Form';
    $txt['required_info'] = 'Required Information';

    NEW:
    $txt['agreement_policy_agree'] = 'Click here to accept';
    $txt['registration_form'] = 'REGISTER BY EMAIL OR SOCIAL NETWORK';
    $txt['required_info'] = 'Email';

    1. Under Configuration > Themes and Layout Settings > Theme Settings, I unchecked "Show news fader on board index."
  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team

    Thank you for the details! Could you please tell me which version of SMF you are using?
    2.0.17, 2.1 RC3 ? Or another version?

Welcome!

Please sign in to your OneAll account to ask a new question or to contribute to the discussions.

Please click on the link below to connect to the forum with your OneAll account.