Error with redirect URL, VKontakte

edited June 19 in Questions

Since VKontakte updated their rules, the OneAll app for SMF 2.1.4 stopped working. The updated rules of VK require that I indicate "Authorized redirect URI" for my website https://strategyconplaza.ru. Otherwise, I get the following error when try to authorize through VKontakte:

{"error":"invalid_request","error_description":"redirect_uri is incorrect, check application redirect uri in the settings page"}

The problem is, I have no idea what should I indicate in the new "Authorized redirect URL" field of VK app. The option that works with Google looking this way: https://strategyconplaza.api.oneall.com/socialize/callback.html – doesn't work with VK.

Any tips?

Answers

  • The problem is solved. There were some outdated values in Oneall Social Networks \ VKontakte \ Setup in the following strings: Website address and Base domain.

    Now I updated them by the new instructions of Oneall and everything now works.

    But it looks that the requirement from VK to indicate Authorized redirect URI is still exists, they write they give a time before September to indicate some value there. I wonder what should I write in this field.

Welcome!

Please sign in to your OneAll account to ask a new question or to contribute to the discussions.

Please click on the link below to connect to the forum with your OneAll account.