Social Login not showing up at all.

edited April 2016 in Joomla!
Hi, first I want to say thank you for creating a wonderful product. Below I will outline every specific step and detail in order to receive the help I need for my problem.

I followed your instructions and documentation for installing the component and module to Joomla! I then input the correct OneAll App ID and necessary details into the forms of the component in Joomla. While still there, I linked my Facebook and Google+ app secrets and IDs to your component. In your component I ran the "test methods" for connections to my OneAll account and it was "success". At the bottom of the component I only checked marked the social logins for Facebook and Google+. At the bottom, I included the URL to your CSS file provided for free.

label repeated:

Now, I assigned the module to a menu item and no icons appeared. I did the same for assigning the module to an open position like in your documentation and social login icons remain invisible. I have repeated "repeated" on cleared cache, cookies, and history on Firefox, Chrome, and IE. I am still unable to solve the issue. What do I do now?

Edit: the site:
I wanted your module to appear on the login menu item once you hover your mouse on it. The component also doesn't load when you click the login menu item and get redirected to the login page using the base Joomla login component.

Best Answer


  • Hi,
    Yes, something looks incorrect because this line of code is missing from the template (which is required to show the icons):
    <div id="oa_social_login_container<?php echo $rnd.$moduleclass_sfx ?>"></div>

    How did you configure the site such that the icons only show when hovered on?

    To first test the install, maybe you can try to display the icons on the login form?
    You need to choose a position to do that.

    You can also, provide a screen shot of Extensions | Modules.

  • Royce_AquinoRoyce_AquinoMember
    edited April 2016

    Thank you. I am unsure where to add that line of code, but it seems it's a hard-code on my part into the view of my template if I'm on the right track. Is it adding it to the index.php or header.php block? I thought the component would do that automatically if the module was called on. So, I tried including that line of code in the header part of the template, but nothing seemed to happen. The template I'm using is the T3 Framework blank. I'm also on the latest Joomla package 3.5.1.

    Here are screenshots of the module configured for the OneSocial Login:
  • Hi,
    Yes, the component adds this line automatically (just thought you may have changed this).

    A basic setup of T3 blank on Joomla 3.5.1 does show the icons (for ex: position-1, on all pages).

    But, this is not setup:
    I wanted your module to appear on the login menu item once you hover your mouse on it.
    I can try to reproduce it, can you give me more information on how to do this?

  • Hi,

    Yes, I will guide you. To have the module incorporated into the menu, create one main menu item in the main menu called login that goes to the component login or a header menu called login, Assuming the OneSocial module is already published and ready to go (doesn't matter what position), head over to templates and select T3 blank. Then Enable Mega-Menu and now go to the Mega-Menu option and you will see an interface of your main menu you chose for the template. Next make a sub-menu to that menu. So now you have a nested menu. Then you can include the module for OneSocial module in that newly created nested menu. Then click save in the Mega-Menu configuration page. Exit out and save template changes.

    I look forward to your response.
  • Hi,
    The result looks ok from here.
    Is this different from your expected result?

  • Hi,

    I created a sub-domain and tried doing the same thing you did and it also works. I decided to back-up my main domain and transfer my database to a freshly installed Joomla after deleting the old main one. As of now I'm in the process of installing extensions again one-by-one. I'll let you know if my problem persists, if I found a conflict with another extension with OneSocial Login. Thanks!
  • Hi,

    So I pretty much finished moving my data and etc. and got most of the extensions installed and it's good.

    If you try to log-in using Facebook though I get an error. I checked the app and it has my domain with wildcard, same with Facebook. How do I fix it?

  • Hi,

    Thanks Fred it worked. However, the Advanced part in my app didn't have Valid OAuth redirect. It is now located in the Facebook login portion that's part of the app.

    As seen here:

    Thank you for all the help!


Please sign in to your OneAll account to ask a new question or to contribute to the discussions.

Please click on the link below to connect to the forum with your OneAll account.