How to translate the phrase 'YOU HAVE CONNECTED WITH FACEBOOK !" (...)

Prestashop 1.6.0.14.

After login via social network (e.g. Facebook), there is a greeting like:
YOU HAVE CONNECTED WITH FACEBOOK !
Please take a minute to review and complete your account information. Once you have reviewed your details, your account is ready to use and you can sign in with Facebook.


I need to translate this text. The only place where I found it is the file:
/upload/themes/default/oneallsociallogin.tpl

Tried to modify the above text in this file - nothing changes.

How to translate this text?
Thank you.

Answers

  • As well, searching for:

    'You have logged in with Facebook
    Please wait, you are being redirected ...'

    Where to search for this phrase? Which file?

    Thanks.
  • Fred_PinelFred_PinelMember
    edited July 2015
    Hi,
    Regarding the tpl, what you have found is correct, but you probably need to clear the cache in prestashop.
    For an example discussion, see https://prestashop.com/forums/topic/159143-contentcode-changes-in-tpl-file-not-updated-in-front-end/.

    Regarding the second question ('You have logged in with Facebook'), you can change this at app.oneall.com -> Site Customization -> Page Templates.

    Hope this helps.
  • edited July 2015
    I'm afraid it's incorrect.

    Cache of Presta cleared, cache of browser cleared, recompile forced. Nothing changed.
    Found the phrase from my 1st question in other file:
    (my theme name)/oneallsociallogin.tpl

    Still searching for the 2nd phrase ('You have logged in with Facebook
    Please wait, you are being redirected ...')
  • So, have you managed to show the translated text for the first text?

    The second phrase is changeable via our app.oneall.com web site.

    Thanks.
  • 1. Yes, the first phrase is translated
    2. The second phrase is not changed after changing language settings at app.oneall.com

    Please advise
    http://internet-shop.by
  • Hi,
    Regarding 2., this is not affected by the language settings, but must be changed in the Template (the next tab).
    You bring up a good point, so we will extend the language settings to also apply to the "You are being redirected..." text.
    Thanks.
  • > must be changed in the Template (the next tab).
    ... however it requires a tolled plan.
    Strange: as I understand, it should have been customizable text, but as result this text even cannot be translated. It's disappointing. No chance to use your service in non-english speaking countries then. Real disappointment.
  • Hi,
    This redirection message is not freely translatable (but still is via the plan), while most text is
    translatable, and is even translated in some languages.
    We will nevertheless address this.
    How suitable this situation is is up to you of course.

    Thanks.
  • Yes, I guess the best workaround is automatic translation this default phrase after changing the language. Looking forward to update from you soon.
Sign In or Register to comment.