These forums are your way of communicating with the community of people developing and using tools provided by the OneAll platform. The forums are run by the community and moderated by the OneAll team during office hours.
Please stick to technical issues - and remember, no confidential information - these are public forums!

400 Bad Request error

Hi,

Is there any way i can modify callback url? While connecting with Facebook i am getting '400 Bad request' error since callback URL trying to connect through SSL on Plain HTTP. So my callback url is something like http://mydomain.ca:443/temp instead of https://mydomain.ca:443/temp. Can i configure and force it to secured connection instead?

Best!

Best Answer

  • Thanks Frederic!

    Wow it start working for me as well. I am pretty sure i haven't touch any settings since issue was reported. I may have to check or will discuss with our IT team.

    Much appreciated.
    Jatinder

Answers

  • Hi,
    Yes, callback URL are customizable.
    To change this we would need to know what is your environment (your own application, or using a plugin for a CMS like Wordpress...).

    Regards.
  • Hi Frederic,

    I am using Drupal Module. I don't see any option to add callback url.

    You can give it a try https://humanrights.ca/templogin

    Please note that it works fine during first attempt i.e. when you are creating a new profile. Problem starts during any further attempts.

    Best
  • Hi Jatinder,
    Your site seems to be working. Anything changed from when you reported the problem?

    Just a thought, :443 only sets the port, but usually not TLS protocol.
    https defaults to port 443, so if that is what you want to do, just choose https and leave out the port.

    Regards.
Sign In or Register to comment.