How to get OneAll's Social Login Buttons to appear on sign in page for mobile view

My OneAll social login buttons appear and work great on my full website page. But if you access the website through mobile view, the oneall social login buttons do not show up in the homepage or the sign in page. Is there anyway we can fix that?

Answers

  • Hi,
    Sure. We'll look into it.
    In what environment are you using the plugin? Is it Vanillaforum as mentioned in the post, or something else, possibly Wordpress?

    Thanks.
  • Frederic,
    Thank you so much! It is a vanilla forum I believe. Here is a link to the website.
    http://www.myneighborgood.com/victoriastationbellsferry/index.php?p=/
    Access it through a mobile and you won't see the register buttons through one all.
    Let me know if I can give any more info!
    Thank you!
  • Hi,
    Indeed, the mobile view does not show the icons, while full site does.

    Maybe you can try out something, in file:
    plugins/OneallSocialLogin/class.oneallsociallogin.plugin.php
    add line:
    'MobileFriendly' => TRUE,
    after the line 14 or so:
    'AuthorEmail' => 'support@oneall.com',
    (but not as the last line).
    You may need to disable/enable the plugin for it to take effect.

    Regards.

  • I really appreciate your help and response with this issue!
    I tried going into notepad and adding such a line but I'm getting errors and it all looks pretty out of my realm.
    Is there any simpler way to do it or could you give more specific directions... eg specifically which line etc.
    Anyways, thank you so much again!
    Sean
  • You're welcome. This is something we'd want to fix.

    Hope this is clearer:
    - First, disable the plugin, from the Vanilla admin dashboard.
    - Then, open the file:
    class.oneallsociallogin.plugin.php
    located in the directory:
    /plugins/OneallSocialLogin/
    - In that file, add this line (including the trailing comma!):
    'MobileFriendly' => TRUE,
    right below the line 14 or so, which should be:
    'AuthorEmail' => 'support@oneall.com',
    (you should not place it after line that says 'AuthorUrl' => 'http://www.oneall.com/' ).
    The block should look like:
    $PluginInfo['OneallSocialLogin'] = array( 'Name' => 'OneAll Social Login', 'Description' => 'Social Login for Vanilla allows your users to login and register with 25+ Social Networks like for example Twitter, Facebook, LinkedIn and Google+.', 'Version' => '1.1', 'RequiredApplications' => array('Vanilla' => '2.0.1'), 'RequiredTheme' => FALSE, 'RequiredPlugins' => FALSE, 'HasLocale' => TRUE, 'SettingsUrl' => '/plugin/oneallsociallogin', 'SettingsPermission' => 'Garden.Settings.Manage', 'Author' => "OneAll", 'AuthorEmail' => 'support@oneall.com', 'MobileFriendly' => TRUE, 'AuthorUrl' => 'http://www.oneall.com/' );
    - Save that file.
    - Enable the plugin.

    Thanks for your help with this. It helps!
Sign In or Register to comment.