Need Help getting social login to work on my site

Hello - I am just trying to get the social login plugin working on my site. The social login was not working - so then I found information that you need to have an account with Oneall for it to work. I did that - and got the "API credentials" and inserted them in my plugin settings in WP. So I tried the social login again and it still did not work.

Now - let me point out something that may be a cause but I have no idea on yes or no...

When signing up on Oneall - I had to "create a site". Now lets say that my site (WP) is mydomain.com
But when signing up - it said my site had to be a subdomain to "oneall" - so i set it up that way.
Lets say that the site setup on oneall account is "wotr1.oneall.com".

In checking further - I found documentation that said I need to create a facebook app for this to work.

So - using my personal facebook account - i then went about creating an app per the directions. One thing is that you had to put the "site address" for the app - and I went ahead and did that - and per the directions on oneall - I put in the "subdomain/oneall" address into my facebook app. When i got this all setup - I tried the social login thing again and still got an error.

So I am not able to get this to work. And the fact that I am dealing with two different site addresses makes this confusing as I am not sure which one goes where. But I am not getting anywhere getting this plugin to work so I am hoping someone can help on here.

Best Answer

  • Fred_PinelFred_PinelMember
    Answer ✓
    Hi,
    You're right, you do not need your own app to login, that would indeed be useless.
    An app is a entry point into Facebook's API, including OAuth, you can then use it for all users.

    You need to set the valid oauth redirect urls, for OneAll that is http://wotr1.api.oneall.com (or https, depending on what you had set in the basic tab.)

    As for the App not setup message, you may need to make this app public (App Review left menu option).

    Hope this helps.

Answers

  • Hi,
    Yes, the key URL is your Oneall subdomain.
    For example: wotr1.api.oneall.com .
    This is need for your WP configuration, and the various social network apps you create (for Facebook: the Valid OAuth redirect URIs shoud be https://wotr1.api.oneall.com/).
    You can test your various social network apps, isolated from the WP settings, from app.oneall.com, in the Developer's corner > Get user token.

    Let us know how this goes.
  • Hello: this is still not working. I have tried setting this up on a totally different domain with almost no plugins to try and ensure there was no "plugin conflict" - but that still did not help. Right now just trying to get facebook social login to work. There are three pieces to this:

    1, the site with plugin (and plugin settings)
    2. the oneall account
    3. the facebook app in my personal facebook account

    Seeing as there could be something wrong with settings in any of the three (or maybe more than one) - it is very hard to know what to try on this to identify why it is not working. Any thoughts on how to approach this? Thanks, Gerard
  • Hi,
    What error are you getting? Is it coming from Facebook? Or is it Wordpress related? (blank page after authenticating with Facebook).

    Otherwise, we can check the components you correctly identified.
    - On Wordpress Oneall settings: the API subdomain should be wotr1 (nothing else).
    The keys come from the app.oneall.com dashboard. You can test those there.
    - On your Oneall account, the key settings are the Facebook credentials. This page also provides you with what you need to put in the last component: your Facebook app.
    - In the Facebook app, the key settings are:
    Basic tab: Web site url (http://wotr1.api.oneall.com/)
    Advanced tab: Client OAuth Settings: the redirect URIs and tick the client and web login oauth.

    Hope this helps.
  • The error is coming from facebook, it opens another window with this message "Given URL is not allowed by the Application configuration: One or more of the given URLs is not allowed by the App's settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains."

    i will check the other settings you mentioned and confirm those are OK as well and repost on here,,,
  • OK - I did change the "website url" in basic tab - and that did allow me to login with facebook when i had the facebook open that I had created the app on...

    so i tested this with another facebook account that has no app and it got a different error: "App Not Setup: This app is still in development mode, and you don't have access to it. Switch to a registered test user or ask an app admin for permissions."

    I dont know if it is still not set up right - or if it is that every person that wants to login has to have the FB app in there FB account (which would make this useless)

    in advance tab: client oauth and web oauth login are both "yes" and "valid oauth redirect urls" is blank (did not know what to put in there)
  • thanks - that appears to have done the trick - I will let you know if I need any more help...
Sign In or Register to comment.