Secure Login HTTPS Drupal 7 bounces to 443 error

I am using Drupal 7 at https://cruisehubs.com

If I turn off Secure login Oneall works as intended but my site is no longer secured HTTPS
If I turn on Secure Login It will fail it redirects and shows user login account with username and email in fields but will not log in.

Is there a fix?


Secure Login allows user login and other forms to be submitted to a configurable secure (HTTPS) URL from the insecure (HTTP) site. By securing the user login forms, a site can enforce secure authenticated sessions, which are immune to session sidejacking.
Secure base URL
The base URL for secure pages. Leave blank to allow Drupal to determine it automatically. It is not allowed to have a trailing slash; Drupal will add it for you. For example: https://cruisehubs.com/drupal. Note that in order for cookies to work, the hostnames in the secure base URL and the insecure base URL must be in the same domain as per the appropriate setting in settings.php, which you may need to modify.
Redirect form pages to secure URL
If enabled, any pages containing the forms enabled below will be redirected to the secure URL. Users can be assured that they are entering their private data on a secure URL, the contents of which have not been tampered with.
Submit all forms to secure URL
If enabled, all forms will be submitted to the secure URL.
Required forms
If enabled, the following forms will be submitted to the secure URL. These forms must be secured in order to implement basic secure login functionality.
User login form
User login block form
User password reset form
User edit form
Optional forms
Other forms accessible to anonymous users may optionally be secured. If enabled, the following forms will be submitted to the secure URL.
User registration form
User password request form
Node form
Comment form

Best Answer

  • Fred_PinelFred_PinelMember
    Answer ✓
    Hi,
    Could you try out the following fix?
    In file: modules/social_login/social_login_widget.module,
    at line 25, replace
    $current_uri = social_login_get_current_url();
    with
    $current_uri = social_login_get_current_url($is_https);
    We'll probably update the plugin about this, if it works :-)
    Thanks!

Answers

  • Hi,
    We'll look into this.
    A first comment: your site seems to be in HTTPS already, with a working Social Login, so I'm not sure I understand the problem you are having.
    Does the problem occur with Secure Login and an HTTP url? (not https://cruisehubs.com/)

    Thanks.
  • Hi again,
    Ok, is the error message you are getting is that plain HTTP content is sent to an SSL port?
    (bad request 400)
  • Frederic_Pinel,

    In file: modules/social_login/social_login_widget.module,
    at line 25, replace
    $current_uri = social_login_get_current_url();

    with
    $current_uri = social_login_get_current_url($is_https);
    Thank you, Success that has corrected the issue I tested Facebook, Twitter, and Google login
    Working as intended!
Sign In or Register to comment.