Stuck on Detecting API Connection Settings. Please wait ...

edited March 2016 in Questions

I seem to be having the same problem many others have posted about with VB5. When I set up the plugin it get stuck on "Detecting API Connection Settings. Please wait ..." As well as on Verifying API key... I have tested the ports, both 443 and 80 are wide open, Curl is installed and supports both http and https. Any help would be greatly appreciated..

phpinfo() curl module:

cURL supportenabled
cURL Information7.35.0
Protocolsdict, file, ftp, ftps, gopher, http, https, imap, imaps, ldap, ldaps, pop3, pop3s, rtmp, rtsp, smtp, smtps, telnet, tftp
SSL VersionOpenSSL/1.0.1f
ZLib Version1.2.8

I have run out of ideas and it seems others are having this issue as well and no solution has been posted neither here nor on
Thanks in advance fr any insight.


  • Hi,
    Sorry for delay.
    One possible cause could be the presence of whitespace in the credentials (domain, keys).

  • Hi Fred, thanks for the reply...I checked everywhere, no white spaces anywhere..also we tried that on 3 separate apache servers and same issue is a professional hosting server which I could see limiting something related to port 443 but one is m6 own private server which I have c9molete access to, same issue..all servers' domains are registered with one all and followed all directions to a t. We would really like to get it going, I I would appreciate any suggestions..I can post any configuration files you would want to see!thanks. I noticed a few posts with this same issue over at the vb5 forum and here there is one- so far haven't seen anything posted with a solution.
  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team
    edited March 2016
    Hi Genya,

    do you see any JavaScript errors in your browser after having clicked on the Autodetection button? What exactly have you entered as subdomain value?

  • Genya_AynegGenya_AynegMember
    edited March 2016
    Hi Claude,
    No I don't see any Java Script errors at all. I have my VB5 install on this domain: so my api is and the sub-domain I entered in VB5's one all setup is pechkin000.

    Additionally, the actual site the VB5 install is part of is done in wordpress so we are doing lofin integration between the two and oneall is also installed on wordpress, and it works flawlessly, using obviously same curl/php on the same apache server its running off. I did a tcp dump when curl contacts oneall api from WORDPRESS install and here is what I see, its totally fine, please see below:

    20:18:41.771753 IP (tos 0x0, ttl 64, id 5525, offset 0, flags [DF], proto TCP (6), length 52) > Flags [F.], cksum 0x8aa4 (incorrect -> 0xb40b), seq 857, ack 5159, win 338, options [nop,nop,TS val 247113554 ecr 2336495343], length 0
    20:18:41.930976 IP (tos 0x0, ttl 50, id 13870, offset 0, flags [DF], proto TCP (6), length 52) > Flags [F.], cksum 0xb4aa (correct), seq 5159, ack 857, win 139, options [nop,nop,TS val 2336495383 ecr 247113554], length 0
    20:18:41.931031 IP (tos 0x0, ttl 64, id 5526, offset 0, flags [DF], proto TCP (6), length 52) > Flags [.], cksum 0x8aa4 (incorrect -> 0xb3ba), seq 858, ack 5160, win 338, options [nop,nop,TS val 247113594 ecr 2336495383], length 0
    20:18:41.937890 IP (tos 0x0, ttl 50, id 13871, offset 0, flags [DF], proto TCP (6), length 52) > Flags [.], cksum 0xb4a7 (correct), seq 5160, ack 858, win 139, options [nop,nop,TS val 2336495385 ecr 247113554], length 0
    However when when I try to do this from VB5 control panel of oneall, its literally blank, so the curl call doesn’t even happen. Everything else works flawless in my VB5 install, and its a totally standard install with basically all default options. Would you have any thoughts? Here is the output of the phpinfo() and couple other tests included in the bottom, everything seems to look as it should, please see if i am missing an extenstion or something thats required but I have no idea at this point what could be causing it:

    Thanks for all the help, we are going to upgrde to a pid account as soon as we resolve this and can go live with it on the site.
  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team
    Hi Genya, I have send you an email ;)
  • Hi, I have not received your email, could you send it to pechkin000 at gmail dot com?
  • edited April 2016
    Hi Claude, we're working with Genya on this problem and he still hasn't received your email. Can you please resend it him or to our email? Also note that the WordPress plugin works fine on both port 80 and 443, while the vBulletin plugin does not. The plugins are on the same domain, on the same machine.

  • It's been two weeks, we've tested with another server with the same results. Please advise.

  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team

    I've once again tried to send it ;)
    Please tell me if you have received it.



Please sign in to your OneAll account to ask a new question or to contribute to the discussions.

Please click on the link below to connect to the forum with your OneAll account.