OAuth Redirect URIs errors


Hi,

First i must say i'm totally noob with API's and a starter with wordpress. I've done every step on your documents so i'm guessing that facebook and G+ api's are ok but i can't get it working.

Facebook error when trying to register:

This redirect failed because the redirect URI is not whitelisted in the app’s Client OAuth Settings. Make sure Client and Web OAuth Login are on and add all your app domains as Valid OAuth Redirect URIs.

G+ error:

400. That’s an error.

Error: redirect_uri_mismatch

Application: registar
The redirect URI in the request: https://zaq123.api.oneall.com/socialize/callback.html did not match a registered redirect URI.

Learn more

Request Details
access_type=offline
approval_prompt=auto
scope=email https://www.googleapis.com/auth/contacts.readonly https://www.googleapis.com/auth/gmail.readonly profile
response_type=code
redirect_uri=https://zaq123.api.oneall.com/socialize/callback.html
state=3fc5f30e-046c-4293-af26-2f52a35a22c5
client_id=491252562177-qgtpc6nlo9kmptt4v8ro8akr550a2uh0.apps.googleusercontent.com


I tried to set up the whitelist but im not sure if it's ok.
My domain is zaq123.esy.es

What can i do about it?

thank you

Answers

  • Hi,
    This is related to social network application configuration.

    For the Facebook error when trying to register:
    "This redirect failed because the redirect URI is not whitelisted in the app’s Client OAuth Settings"
    This means you need to add a URL into the Facebook settings, goto Settings menu, Advanced tab, and in the field "Valid OAuth redirect URIs", type in http://zaq123.api.oneall.com/ (or https).

    Same thing for the Google application.

    Regards
Sign In or Register to comment.