We are glad to welcome you to our Community Support Forums!
These forums are your way of communicating with the community of people developing and using tools provided by the OneAll platform.
The forums are run by the community and moderated by the OneAll team during office hours. Please stick to technical issues - and remember, no confidential information - these are public forums!

No "interested in gender" returned for Facebook

Hi, it seems that OneAll does not return the "interested in gender" field for Facebook. Is this implemented and if not, can it be added in any forseeable future?

Answers

  • Hi,
    This should be available.
    On app.oneall.com, go to the Social Networks / Facebook and tick the appropriate field (Relationships, gender interests).

    Regards
  • I've checked and rechecked it and it doesn't seem to work. It always returns only the "status" field, not the "interested_in":

    image

    I believe all permissions are properly set, both in OneAll and Facebook App, see the screenshots below. They're in Polish, hope you don't mind.

    image

    image

    image
  • Hi,
    This is strange.
    To troubleshoot this, in your Facebook account settings, you can remove the app autorization for your Facebook app.
    This will allow the Facebook login popup to show the scope requested.
    You can then check if the user_relationship_details is one of them.
    Also, for this account, make sure you have specified some gender interest (profile, contact and basic info section).
    And check what you get from Oneall.

    Hope this helps.
  • I've tried everything, this doesn't seem to work.
  • Hi,
    If you are testing with a Facebook account you own, can you check what the application settings (permissions) from:
    https://facebook.com/settings?tab=applications.
    Locate the app for your site, and by clicking on the icon, it should list the the info you provide to this app, and should include the "relationship interests".
  • Hi,
    Everything in the app for the account is enabled and the accessibility is set to public. The "interested in" field is set and is also set to be publicly visible. Basically, it's set the same as gender. The gender is being returned, but "interested in" is not.
  • Hi Radosław,

    our API should already include the "intereste_in" information. I have seen that you have multiple OneAll site. Could you tell me for which OneAll site you would retrieve the information? We will then make some more tests.

    Regards,
  • I am testing this on the "QAHorizon" site
  • Oneall Team,

    any updates on that? We still can't get gender inerests in the response.

    Thanks
    Pawel
  • edited May 31
    Hello,

    to retrieve this value, please first make sure that you have enabled this option in the OneAll Facebook setup:
    Relationship, Gender Interests

    Then please go to the App Review panel of your Facebook app and make sure that this permission has been approved:
    user_relationship_details

    When the user now logs in with Facebook the following node will be included in the user's data that you pull from our API:
    "relationship": {
    "interested_in": "Female"
    }
  • edited June 19
    Hi Claude,

    thank you for your answer. We ensured that our app is configured as you described. Now I can see that 'interested_in' field is being returned by /connection/****.json ednpoint but is not included in identities/***/synchronize.json response.
    The latter is what we'd like to use to get that value from. Is or will that be possible at some point?

    Thanks
    Pawel
  • edited June 20
    Hi Pawel,

    it's very like that the user has not given his consent for the "user_relationship_details" scope. Could you please make sure that the permission is enabled (as described in my previous post). Then login using Facebook and then refresh that identity.
    Please tell me if you then get the value.

    Regards
Sign in with your OneAll account to take part in the discussion.