Timeout when linking accounts

I just installed the Oneall plugin into my Wordpress site, and it seems to work fine, but when I try linking my existing account to my Facebook account, I get:

This site can’t be reached

saintjameslutheran.com took too long to respond.
Checking the connection

I notice that the port it's trying to use is 15656. Could that have something to do with it, especially since I'm using a caching site?


  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team
    Hi Dale,

    could you please post a link to your website?
    I will have a look and help you fix the issue.

  • And now, I can't even login. I keep getting the login screen, enter email/password, back to the login screen without even an error, and I'm not even using the OneAll options. Going to have to delete the plugin if I can't get this figured out. Help is appreciated.
  • Hate to be impatient on this. At this point, the "can't login at all" problem supersedes the "can't connect accounts" issue. Any thoughts? I'm really impressed with how easy this plugin was to set up compared to the others like it, so I really don't want to delete it, but I can't stay locked out of my site, either. Thanks.
  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team
    edited October 2016
    With your current server configuration, Social Login seems to add the port when it should not do it.

    Could you please open the file toolbox.php of the Social Login plugin?
    You can edit the file in your WordPress admin area under Plugins>Editor>Social Login.

    Then please replace this line:
    $request_port = (!in_array ($request_port, array (80, 443)) ? $request_port : '');

    $request_port = (!in_array ($request_port, array (80, 443, 15656)) ? $request_port : '');
  • OK, edited in my dev site (which I can't actually test since it has a different URL). Still can't login. Just keeps returning me to the login screen, no error message.

    Not sure whether this is a clue, but when I click the "Sign in w/ username & password" at http://saintjameslutheran.com/wp-login.php?redirect_to=http://saintjameslutheran.com/wp-admin/&reauth=1 there's a lot of whitespace between the login icons & the Powered by OneAll message .

    I was able to create an account using my Google login (which I haven't created yet on this site, so it's a new account, not logging into the old one), and it created the account (I got the email about a new account), but it returned me to the login screen and wanted my password.
  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team
    Hi Dale,

    could you have a look at your PHP error logs and check if you see something about our plugin?

    If there are not errors, could you then please download/install this version of social login?

    Simply deactivate/remove the current version then upload and activate this version.

    You will then find a new option "Allow other plugins to change the redirection url that you have chosen by using a hook/filter?" in the social login settings. Could you please try to activate that setting and tell me if the redirection works then?
  • Nothing in the PHP error log.

    Installed the new plugin. Here's where it gets weird:

    I can login on live-saintjameslutheran.pantheonsite.io, which is the same site, same location, but still getting the 15656 error when I try to connect my social media account to my existing profile, but now, it says it "Refused to connect," although I'm guessing guessing that has something to do with those social apps looking for the saintjameslutheran.com domain.

    But when I try logging in at saintjameslutheran.com, I still get the same login problem as before: back to the same page without doing anything.

    And I checked with a couple other people, and they have no problem logging onto saintjameslutheran.com.

    Hold on, I just tried it in different browser, and it worked.

    //Clear cache (Mac OS Chrome), quit & restart, still doesn't work, delete cookies for the site, SUCCESS! Able to login.

    Try connecting profile to Facebook…
    You have logged in with Facebook
    Please wait, you are being redirected ...
    This site can’t be reached

    saintjameslutheran.com took too long to respond.

    Back to the original problem, but at least I can login to the site. Don't know whether that has anything to do with the modified plugin. I tried the above patch to the uploaded plugin.

    SUCCESS!!! Thank-you!

    So now, I have been able to link my Facebook account, but the Twitter & Google accounts won't, because it says, "The social profile is linked to another user." That would be when I was trying to set up accounts. Is there a way to break those so I can connect them to the right profile?

    Thanks again.


Please sign in to your OneAll account to ask a new question or to contribute to the discussions.

Please click on the link below to connect to the forum with your OneAll account.