Login works, but does not redirect anywhere

I'm using Chrome and developing my site on my localhost, and when I login, which works, it goes to a redirect page, which hangs indefinitely like so:


Am I doing something wrong?


  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team

    could you please open the Social Login settings in your WP admin area and click on "Autodetect" and "Verify".
    Do you get a green success message for each of the tests?

  • Hi Claude,

    I took a second look, and it turns out that the Verify wasn't working -- so I went back into my OA portal and got the right ones int there and it worked.

    Then I tried to login on my site through Google and Facebook again and got the same behavior.

    One thing I noticed earlier today as well as right now is that the if I just X out of the redirect page and re-visit my site, I am indeed logged in as the user from that social network.

    It's just that the redirect isn't working still.
  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team
    Hi James,

    could you please download/install this version of social login?

    Simply deactivate/remove the current version then upload and activate this version.

    You will then find a new option "Allow other plugins to change the redirection url that you have chosen by using a hook/filter?" in the social login settings. Could you please try to activate that setting and tell me if the redirection works then?
  • Great that fixed the problem -- I didn't even have to enable that new option. As a matter of fact it looks like it was already chosen.

    What was the problem I wonder?
  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team
    Our plugin allows other plugins to change the redirection (by exposing a hook). In your case another plugin is responsible for the wrong redirection. The new plugin version disabled the modification of the redirection url and fixed the error.
  • That is possible, I had attempted another social login plugin before settling with oneall -- that could well have been the culprit. This was actually from a new install, and that is the only factor that comes to mind right now.

    Thanks Claude!


Please sign in to your OneAll account to ask a new question or to contribute to the discussions.

Please click on the link below to connect to the forum with your OneAll account.