returning user login not working joomla 3.6.5

edited February 2017 in Joomla!
hello
i have installed OneAll social login component for joomla 3, enabled the oneAll module , first time a user uses one of the social networks everything works ok.
after logout, that user can't login again ,no error message is shown not even in logs.
i tried to pin point the problem
i went through the oneAll social login plugin in /plugins/system/
the returning user is found but the login not working
//every test before this line is valid
$result = $app->triggerEvent ('onUserLogin', array ((array) $response, $options));

any ideas what can cause this .

ps : when deleting the user and logging in again with social network it works. only when a returning user try to login it fails.

please help this is urgent.

Answers

  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team
    edited January 2017
    Hello,

    I have now installed a brand new version of Joomla 3.6.5 in our test environment and I unfortunately could not reproduce the error. I tried to register, logout, login with Facebook and Twitter but it always worked.

    Could you try to add this after $result:
    print_($result); exit;

    In this line we call the event onUserLogin:
    $result = $app->triggerEvent ('onUserLogin', array ((array) $response, $options));

    Other extensions can hook up the event, and then their own code is called too.
    Maybe there is an error somewhere else. Try to search for onUserLogin in the php files in your Joomla folder.
Sign In or Register to comment.