These forums are your way of communicating with the community of people developing and using tools provided by the OneAll platform. The forums are run by the community and moderated by the OneAll team during office hours.
Please stick to technical issues - and remember, no confidential information - these are public forums!

Redirect to oneallsociallogin/index.php

Hi,
I have vbulletin 4.2.5 and the oneall plugin appears with all my networks. But after the successful login on the external page eg. Facebook, it always redirects me back to oneallsociallogin/index.php which doesn't exist. Login fail too. Couldn't find any social network where I don't have this issue.
What I need to do?

Answers

  • Hi Michael,

    could you please post a link to your forum?
    I will have a look.

    Regards,
  • Any ideas, why it doesn't work?
  • edited November 2017
    Hi Michael,

    could you please acces your vBulletin using FTP and check if you have this folder at the root of your forum?
    oneallsociallogin
  • Hi Claude,
    yes the folder is there.
  • Hi Michael,

    we have been able to reproduce the error and release a new version today.

    Could you please uninstall your current version and install the new version here:
    https://github.com/oneall/social-login-vbulletin

    It's not enough to simply copy/paste the files. You have to uninstall/install the plugin so that the templates are updated too.

    Best Regards,
  • edited December 2017
    Thank you for the fast support.

    Maybe I did it wrong. I uploaded first and tried to uninstall.
    Got following error message:
    syntax error, unexpected 'DROP' (T_STRING) on line 4 in /home/.sites/xxxxxxxxx/admincp/plugin.php(1562) : eval()'d code #0 {main} Fatal User Error: syntax error, unexpected 'DROP' (T_STRING) on line 4 in ..../admincp/plugin.php(1562) : eval()'d code in ..../vb/vb.php on line 286 Trace Data: #1 : vbstop() called in ..../includes/class_core.php on line 6089 #2 : vbulletin_error_handler() called in on line #3 : trigger_error() called in ..../vb/vb.php on line 286 #4 : vB::handleException() called in on line Var Type: [ NULL ] Var Data: null
    I tried to simply overwrite the product but getting the same error. Even here, no uninstall is possible.
  • edited December 2017
    Hi Michael,

    there was unfortunately a bug in the uninstall code of the previous version of the plugin.
    Replacing the files with a new version does not fix the issue, as the code with the error is stored in the database.

    There are two possibilites to fix it:

    1) Run the following code in your database
    UPDATE productcode SET uninstallcode=REPLACE(uninstallcode, '""DROP', '"DROP') WHERE productid='oneallsociallogin';

    2) Or
    - Login to your AdminCP, - Goto Products & Hooks -> Manage Products - Look for OneAll Social Login and edit the plugin - Look for Uninstall Code and replace ""DROP by "DROP
    This fixes the uninstaller.
  • edited December 2017
    The update worked now, but it still redirects me to the error page. I tried now following, which brought a different result.

    my htaccess file which I had before:
    RewriteEngine On RewriteBase / # www is redirected to base domain RewriteCond %{HTTP_HOST} ^www\.([^\.]+\.[^\.]+)$ RewriteRule ^(.*)$ https://%1/$1 [L,R=301] # base domain should use HTTPS RewriteCond %{HTTPS} off RewriteCond %{HTTP_HOST} ^[^\.]+\.[^\.]+$ RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [L,R=301] # other domain should use HTTP RewriteCond %{HTTPS} on RewriteCond %{HTTP_HOST} !^[^\.]+\.[^\.]+$ RewriteRule ^(.*)$ http://%{HTTP_HOST}/$1 [L,R=301]

    I changed this now to:
    RewriteEngine On RewriteCond %{HTTPS} off RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    The result was, that in 2 of 3 cases I still got the error page but when I opened again the base domain I was logged in. For the one case I had to re-login into Facebook due the deletion of all browser data.
Sign In or Register to comment.