Compatability with phpbb 3.2.1

Is the current version compatible with phpbb 3.2.1? Thinking of adding it to a new forum.

Thanks

Answers

Sign In or Register to comment.