Error in the user's name account! Facebook User, Google User

Hi. I installed the module in drupal 8 and log in with Facebook and Google, and it worked very well, the only problem is that it did not take the google avatar image.
This week I moved the site to a new server under a new domain that will be the final, so I created a new account and following all the steps as in the previous. But now it does not recognize the user's name, only Facebookuser, Googleuser, comes out, so it generates new accounts every time someone try to login, Facebookuser1, Facebookuser2, and so on. At this time, he does not take the facebook avatar and my personal account is blocked.
I have no idea how being the same site, the same installed module is happening this. The only difference is that the new domain is HTTPS, can that be the problem?
Site 1: http://editorialeducativa.org
Site 2: https://edalgo.org
It is very necessary to solve this to launch the site, since it is a required functionality for the use of the site. Thanks.

Best Answer

  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team
    edited March 25 Answer ✓

    Hello,

    This week I moved the site to a new server under a new domain that will be the final, so I created a new account and following all the steps as in the previous.

    the thing is that you have site created a new account and OneAll site, so the users will be recreated as they don't existing in that OneAll repository yet.

    Even if you move to another domain, you do NOT need to create a new OneAll account or new OneAll site. Just whitelist the new domain in your settings.

    Regards,

Answers

  • Thank you for your quick response. Even though it seems that it won't retrieve facebook avatar, what can I do with that.
    Thanks again

Sign In or Register to comment.