Facebook won't connect but others do.

edited July 18 in WordPress

In using the social Login I am able to connect (seeing the green) with Discord, Twitch, Steam (That's what I have set up thus far). However, when trying to test Facebook, all it does is run a continuous loading symbol. The popup window comes up, asks for the login and info, you click the button, and it just shows a loading page, but never does anything.

Now if I go to my site, and click the "facebook login" I get the following message:

An error has occurred while processing the request
[Site:] Could not connect to Facebook
Please verify the Facebook configuration in your OneAll account. If you are the owner of this website then you need to follow the setup guide available here: Setup Facebook Configuration

I followed all the directions for setting up Facebook and I also have it turned on and "Live"

Also to note, when I test the above social sites, they all (but Facebook) show green and valid, However, when going to my site, and clicking on the icons, they all give those error messages.

Best Answer

  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team
    edited August 12 Answer ✓

    Hi Mark,

    I see the issue. In your OneAll screenshot your have this subdomain:
    gamerzfanarcade

    In the screenshot of your website you have this subdomain:
    gamerzfanaracde

    They are NOT the same.

    So if you setup Facebook in your OneAll account, the settings will NOT be used on your website, because the subdomains are different.

    If everything EXCEPT Facebook is working, then please login in the OneAll account that that has the subdomain gamerzfanaracde (the one used on your website) and setup Facebook there.

Answers

  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team

    Hi Mark,

    could you please make sure that in the Social Login settings in your WordPress you are actually using the same subdomain as the one displayed on your OneAll account.

    It could be possible that you have accidentally created two different OneAll accounts and that you are actually managing the social network setup in one account, but using a different account in your WordPress setup.

    Regards,

  • One All Account

    Website

    Is that what you mean?

  • Claude_SchlesserClaude_SchlesserAdministratorOneAll Team

    Ok. That looks great. Could you post a link to your website? I will have a closer look.

  • Were you able to identify any issues? Or is it just something I messed up?

    I know under API Access on Oneall is different than the API Settings on the website. But if I try to change them on the website to match the ones on Oneall, it gives an error message.

    So not sure how those actually work together. Or it might not even have anything to do with that. I do know that Facebook disabled the app on their side due to the issue with the login not working.

  • Or maybe just delete it all and start over? lol

  • Ahhh! I can't believe I missed that !! I adjusted it and fixed up the private and public key, and I was able to connect with "Discord".

    But now, when I try to connect with Facebook, It just shows a loading page and never loads. (I deleted and created a new app, and changed all the info as well)

  • Oh, when I try to test it on oneall site, or try to login through my site, It just comes up and keeps showing the loading window. That's just weird. Maybe it's something on my end then

  • Yep, it was something on my end, I switched to Chrome, and it connected right off the bat.

    Thank you for all your help !! And my stupid mistake lol

Sign In or Register to comment.